GraSu Community

Înregistrează-te !
E rapid și ușor !
Scapi de reclame si vizualizezi tot conținutul forumului
Postezi mesajele tale
Primesti ajutor din partea comunității
(peste 1200 membri !!)

LINEUP ASII # Girls


Jucator 1
Jucator 2
Jucator 3
Jucator 4
Jucator 5
ASII # Girls
Adversar # Detalii
vs DW * #      
vs DsWW #      
vs gxGw #      
ASII # Girls
Adversar # Rezultat
vs R0k #      3-16
vs uSp #      16-6
vs neXt!LadiEs #      15-16
GraSu.LaLeagane.Ro

Redirecte GraSu


Algoritmi elementari(exemple pseudocod)

Vezi subiectul anterior Vezi subiectul urmator In jos

Algoritmi elementari(exemple pseudocod)

Mesaj Scris de faNta la data de Dum Aug 02, 2009 8:02 am

Algoritmii elementari sunt algoritmi simpli care ne ajuta în rezolvarea problemelor.
Exemple de algoritmi elementari:
-interschimbare
-determinarea minimului/maximului
-prelucrarea cifrelor unui numar
-calcularea celui mai mare divizor comun
-testarea unui numar prim
-conversii între sisteme de numeratii
-generarea sirurilor recurente

Prin interschimbare întelegem ca 2 variabile ai si b îsi schimba reciproc valorile initiale prin intermediul unei variabile auxiliare.
Ex a=12 b=-3
aux=a
a=b
b=aux
Pseudocod
Început
Citeste a,b
aux=a
a=b
b=aux
Scrie a,b
Sfârsit

Determinarea maximului
Ex: Se da un sir de numere întregi formate din 3 cifre. Si se determine maximul acestui sir.
n=5 -2,14,-32,158,4
Pseudocod
Început
Citeste n
max=-999
Pentru contor=1,n executa
citeste a
Daca (max atunci max=a
Sfârsit_daca
Sfarsit_pentru
Scrie max
Sfîrsit

Explicatii: n este lungimea sirului. am initializat maximul cu cel mai mic nr întreg de 3 cifre si anume -999. Mai departe va compara acest numar cu primul din sir si evindent fiind mai mic noul maxim va fi primul nr din sirul dat. Tot asa si mai departe prin comparatii repetate se va determina maximul.

faNta
♥ FAN ASII ♥


Sus In jos

Vezi subiectul anterior Vezi subiectul urmator Sus


Permisiunile acestui forum:
Nu puteti raspunde la subiectele acestui forum